If You Are Installing for the First Time

If you are plugging in your device for the first time and you have a black screen appear this is most likely a power or an input issue. 

Ensure that you have the power connected to the chromebit as seen in the Quick Setup Guide and make sure it is connected to a working power source. If you already have the device connected to a working power source, unplug and reconnect the power cord. 

Once you have double checked your power source, you will need to ensure that you have plugged the chromebit into a working input and that this input is the input that is showing up on your screen. 

If you are having issues with the current input you are trying to plug into, we recommend trying the device in a different input or TV you know is fully operational to ensure that the chromebit is working properly. 

If You Have Been Plugged in for a While

If your device has lost internet connection and has been offline for a period of time it may have gone to sleep causing a black screen. To “wake up” your device, unplug the power cord and reconnect to reestablish a connection. 

Once you have double checked your power source you will need to ensure that you have plugged the chromebit into a working input and that this input is the input that is showing up on your screen. 

If you are having issues with the current input you are trying to plug into, we recommend trying the device in a different input or TV you know is fully operational to ensure that the chromebit is working properly.

Did this answer your question?